Results 1 to 7 of 7

Thread: Windows Says Disk is Write Protected

  1. #1
    Senior Member TonyMan's Avatar
    Join Date
    Mar 1999
    Location
    Lisle, IL
    Posts
    783

    Windows Says Disk is Write Protected

    The D drive (Samsung SSD) had all my Data - Pictures, Documents, etc. Cloned my D drive to an NVMe on a USB adapter, removed the SSD, installed the NVMe on a PCIE adapter, and changed its drive letter to D.

    Since then I have two issues:

    1. Windows says the D drive is write protected. I've tried a few things I've found on line, Diskpart, Registry edit, etc., but nothing changed.

    2. After any restart, File Explorer does not see the D drive. I have to go into disk management and assign the letter D to the partition.

    3. The maker of the adapter said, "The drive was cloned or prep previously using a different method as a result it will not see it correctly here. If Windows can see the files as write-protected, you can copy to somewhere else, wipe the drive by re-prepping it (initialize, partition, and format) and restore the data back." I could not format it in Disk Management, but was able to with AOMEI Partition Manager, but Windows still says it's write protected.

    Any ideas appreciated.

    Windows 11
    MSI B450-A PRO MAX
    AMD Ryzen 7 5700G
    C drive - Samsung 980 PRO 1TB
    D drive - Samsung 970 EVOPlus 500GB (the write protected one)
    Strange women lyin' in ponds distributin' swords is no basis for a form of government.

  2. #2
    Administrator Steve R Jones's Avatar
    Join Date
    May 1999
    Location
    Largo, FL.
    Posts
    5,276
    Is there a CD/DVD drive? If so, change it's drive letter to E to get it out of the way.

    Google-> "Take Ownership" and see if doing that helps.
    "Vegetarians live up to nine years longer than the rest of us...Nine horrible, worthless, baconless years."

  3. #3
    Senior Member TonyMan's Avatar
    Join Date
    Mar 1999
    Location
    Lisle, IL
    Posts
    783
    There is no conflict with the DVD. It is F. I've tried the NMVe as D, E, P, and Q ti insure there is no conflict.

    I also pulled the NMVe, put it on a USB adapter, plugged it into my wife's PC, and that said it was write protected also. Almost seems like a hardware issue on it. Very strange.
    Strange women lyin' in ponds distributin' swords is no basis for a form of government.

  4. #4
    Administrator Steve R Jones's Avatar
    Join Date
    May 1999
    Location
    Largo, FL.
    Posts
    5,276
    Quote Originally Posted by Steve R Jones View Post

    Google-> "Take Ownership" and see if doing that helps.
    Were you able to look into this?

  5. #5
    Senior Member TonyMan's Avatar
    Join Date
    Mar 1999
    Location
    Lisle, IL
    Posts
    783
    Sorry, I misunderstood that, will check it out today and report back.
    Strange women lyin' in ponds distributin' swords is no basis for a form of government.

  6. #6
    Senior Member TonyMan's Avatar
    Join Date
    Mar 1999
    Location
    Lisle, IL
    Posts
    783
    The articles I found say to right click on the drive, then Properties/Show more options/Take ownership. I do not have a Take Ownership option in the menu. And I am signed in as administrator.

    I found another one that said to use Command Prompt. When I try to direct to the drive, I get a response saying it's write protected.
    Strange women lyin' in ponds distributin' swords is no basis for a form of government.

  7. #7
    Senior Member TonyMan's Avatar
    Join Date
    Mar 1999
    Location
    Lisle, IL
    Posts
    783
    Issue is resolved. I had also written to the manufacturer of the PCIe adapter. They said to initialize the disk using the diskpart clean command in CMD. I can now move files to it and it shows up after a restart.

    Thanks for your help, I appreciate it.
    Strange women lyin' in ponds distributin' swords is no basis for a form of government.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •