Right, I'm not sure if anyone will ahve had this problem before or know of how to fix it, but I don't fancy a compleet reformat so here goes.

Today, when trying to open a program from the start menu in windows XP pro, it came up with a missing link mesage box. When I tried to manualy search for the program in the program files folder, I got to the folder the program is stored in and tried to open it. At this point, windows sat for a few seconds before retuning the message "The disk in drive c: is not formated. Would you like to format it now?". Obviousley I clicked no, and tried to get into the file though explorer but cam up against the same message.

Now I know the disk must be formated (at least for the most part), as I am running windows and quite a few other program right from it now. So I am very confused as to how only a part of the drive is unformated, especialy seen as how it was working earlier on today. I also tried doing a scandisk to see if that would pick it up and fix it, but that bombed out halfway through saying it couldn't compleet the task.

So does anyone know anyway I might be able to solve this problem, or am I going to have to reformat the whole thing and spend a day or so reinstalling everything onto the fresh partition?