dcsimg
Results 1 to 3 of 3

Thread: Parallel port inactive in Linux when 25 pin cable plugged into it.

  1. #1
    Member
    Join Date
    Nov 2002
    Location
    Albany, IL
    Posts
    169

    Parallel port inactive in Linux when 25 pin cable plugged into it.

    Background:
    I would like to be able to print with an old spare computer using the parallel port (it has USB ports, but none of them work - I got it cheap).

    Here is the problem: The simple act of plugging a 25 pin cable into the port disables the port in Linux Mint, Ubuntu, or Fedora. The cable does not even have to be connected to the printer to cause this effect. The evidence that this is not a hardware problem is basic, but in my opinion valid. One of the HDD's has a dual boot with Windows 7, and the parallel port remains active in Windows 7 under this condition.

    my-pc@my-pc(with cable in port):~$ dmesg | grep parport
    [ 4.013473] parport_pc 00:04: reported by Plug and Play ACPI
    my-pc@my-pc(with cable in port):~$

    should read:

    my-pc@my-pc(without cable in port):~$ dmesg | grep parport
    [ 4.065798] parport_pc 00:04: reported by Plug and Play ACPI
    [ 4.065885] parport0: PC-style at 0x378 (0x778), irq 7, using FIFO [PCSPP,TRISTATE,COMPAT,EPP,ECP]
    [ 4.160057] lp0: using parport0 (interrupt-driven).
    my-pc@my-pc(without cable in port):~$

    There is some history from some time ago (>5 years) about this problem, and some had success adding statements to an /etc/modules configuration file. I have tried all those ideas without success.

    Any thoughts/ideas what to do next?

  2. #2
    Member
    Join Date
    Nov 2002
    Location
    Albany, IL
    Posts
    169
    I have reverted to a legacy version of Fedora and stumbled upon a clue. At first website below there is reference to etc/modules directory.

    https://www.vmware.com/support/ws5/d...ure_linux.html

    On this older version of Fedora, it had an etc/modules-load.d directory, but it was empty. Right next to it was an etc/modprobe.d directory. Second website below has a reference to that.

    https://www.kernel.org/doc/html/v4.1...e/parport.html

    In the etc/modprobe.d directory is an openfwwf.conf file. If I add the following lines to it (per 2nd website):

    alias parport_lowlevel parport_pc
    options parport_pc io=0x378 irq=auto

    ..the parallel port now remains operable with the cable and printer plugged in.

  3. #3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •