Results 1 to 2 of 2

Thread: Asus WL-138g Drivers, Win7

  1. #1
    Senior Member too_much's Avatar
    Join Date
    Oct 2002

    Asus WL-138g Drivers, Win7

    Hi all

    This may seem incredibly lazy, but it's really not. I've recently installed Windows 7, and I have a PCI Asus WL-138g wi-fi card which worked absolutely fine under XP and Vista.

    Windows 7 doesn't pick it up automatically, and there are seemingly no specific Win 7 drivers for it. Every single vista driver I've tried from googling (over several hours) has resulted in nothing. The one from the actual Asus website just says "extracting ASUSDIFx.exe" (takes about 0.2secs but I screenshotted it) then says completed - and does nothing.

    I can't find any install path at all, and the only files relating to that are in the Windows\Prefetch folder.

    Am I missing something obvious? I tried running it under "troubleshoot compatibility" but it won't even open the compatibility options.

    I'm sure you have better things to do than trawl the internet for drivers for me, but if someone has the same issue, or knows of a better source of drivers, please let me know.

    I tried the Marvell website as that's the chipset it uses, but they ask for a "product number" which starts with 88 - the only thing on the PCI card itself along those lines is 88W8310-BAN on the Marvell chip, but there doesn't seem to be ANY Libertas (PCI) support, only Yukon (Ethernet).

    Surely this isn't completely incompatible? It's only a PCI card, not exactly advanced!

    If anyone has any suggestions, please let me know

    Kind regards

  2. #2
    Lifetime Friend of Staff
    Join Date
    May 2007
    Sheboygan, WI
    Look for a C:\ASUS folder.

    Should be there and in it a .inf file.

    Note the name.
    Go into device manager, to the nic, click it and select install driver, browse to the .inf file and it should install just fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts