dcsimg
Results 1 to 12 of 12

Thread: DMA enable

  1. #1
    Member orkboss's Avatar
    Join Date
    Dec 1999
    Location
    Sheppey, Kent, England
    Posts
    345

    DMA enable

    I cannot DMA enable my hard drive in the device manager properties. When I reboot after ticking the box the tick disappears.

    Mobo Elite groups K7VZA
    Processor 800 Mhz Duron
    Hard drive 15GB Maxtor DiamondMax Plus 45 Ultra ATA100

  2. #2
    Member Hearie's Avatar
    Join Date
    Sep 2002
    Location
    IM RIGHT HERE!!!
    Posts
    409
    Do you have this setup in the BIOS? Might also be a jumper on the board.

  3. #3
    Extreme Member! BipolarBill's Avatar
    Join Date
    Oct 2000
    Location
    Norton Noo Joisey
    Posts
    41,522
    You need to install the VIA 4in1 drivers:

    http://www.viaarena.com/?PageID=2
    MS MCP, MCSE

  4. #4
    Member orkboss's Avatar
    Join Date
    Dec 1999
    Location
    Sheppey, Kent, England
    Posts
    345
    Will try this out. I did not install the VIA 4 in 1 driver and used the windows one as I have a Voodoo 3 3000 AGP card. I have heard that this can cause incompatibility troubles. Well hey that discribes any piece of hardware with windows!!!

  5. #5
    Member smily_03's Avatar
    Join Date
    Sep 2001
    Location
    A little east of nowhere
    Posts
    387
    when you install the 4 in 1's (now hyperion), you can select which drivers you want to install, so if you don't want to install the agp drivers or whatever you don't have to. i would definitely do the ide drivers though...
    +-------+
    CCNA Cisco Certified Networking Associate

  6. #6
    Member orkboss's Avatar
    Join Date
    Dec 1999
    Location
    Sheppey, Kent, England
    Posts
    345
    I downloaded and installed the new Hyperion Via drivers and there was still no change. I cannot select the drive to DMA enable.

    I tried to flash the bios next which I did not do succesfully dispite reading the website instructions thoroughly. The Flash software stopped when it came up with the error message "Unknown Flash Type".

    This is also the message I get when booting up my computer now instead of "Verifying DMI Pool".

  7. #7
    Extreme Member! BipolarBill's Avatar
    Join Date
    Oct 2000
    Location
    Norton Noo Joisey
    Posts
    41,522
    When yuou flash the BIOS , you have to type the entire name of the file (i.e. NEWBIOS.ROM, 100303.BIN). What I like to do is rename the file to NEWBIOS.xxx and the flasher to FLASH.EXE. It makes things easier.

    Clear the CMOS on the motherboard and try changing the IDE cable.
    This is also the message I get when booting up my computer now instead of "Verifying DMI Pool".
    Does the system stop at that point?
    MS MCP, MCSE

  8. #8
    Member orkboss's Avatar
    Join Date
    Dec 1999
    Location
    Sheppey, Kent, England
    Posts
    345
    I did type the complete name of the new flash bios. At first I did not add the extension and the award flash program came up with the error "No source file" Or spomething but I got past this stage when I added the extension. I have somehow managed to restore my system as the flash messages has disappeared. I was trying to restore my old bios and I guess I have done it.

    Oddly the error had no effect on the computer.

  9. #9
    Extreme Member! BipolarBill's Avatar
    Join Date
    Oct 2000
    Location
    Norton Noo Joisey
    Posts
    41,522
    Well, for some fixes, you really have to "be there" - ya know?
    MS MCP, MCSE

  10. #10
    Banned
    Join Date
    Apr 2002
    Location
    London UK
    Posts
    1,185
    i didnt have the correct dma type on my hard drive cause the jumpers settings on the hd where on cabel select not master slave play around with that

  11. #11
    Member orkboss's Avatar
    Join Date
    Dec 1999
    Location
    Sheppey, Kent, England
    Posts
    345
    I will try with the jumpers but I am positive I set them correctly. I have also tried changing over IDE cable. What I will next do however is get my old hard drive from the step sons computer, put that back in and see if I can DMA enable this. That way we can tell if the trouble is with the hard drive or the motherboard (or software).

  12. #12
    Ultimate Member mrrobotto's Avatar
    Join Date
    Feb 2003
    Location
    Ohio
    Posts
    2,447
    Try this see if it helps you out any.

    I cannot enable the DMA checkbox in the Windows Device Manager.

    Award BIOS’s dated prior to 10/28/98 may prevent Windows 95/98/ME and Windows NT from performing Ultra ATA (UDMA) transfers with a hard drive installed that is capable of supporting Ultra ATA/66, Ultra ATA/100, or Ultra ATA/133.

    This issue has been observed to only affect systems and motherboards with the following conditions:

    ·The system contains an Award BIOS dated prior to 10/28/98.

    · The system contains a core logic chip set capable of only supporting up to UDMA mode 2 (Ultra ATA/33).

    · The system has a hard drive installed that supports Ultra ATA/66, Ultra ATA/100, or Ultra ATA/133 (UDMA mode 4, mode 5, or mode 6 respectively).

    For Windows 95/98/ME based systems the typical reported symptom is that the DMA "check-box" in Device Manager for the specific hard drive will not stay enabled after a system reset.

    The worst case scenario is that under Windows 95/98 the hard drive may be forced to run in "MS-DOS compatibility mode" until UDMA is disabled in the system BIOS.
    In the case of Windows NT, the symptom may likely manifest itself as a small reduction in hard drive performance. In most cases though, the hard drive continues to run normally under the operating system default of PIO mode-4 (which is the Windows 95/98/NT default transfer rate for all Ultra ATA hard drives).

    The best resolution is to contact your system or motherboard manufacturer for a BIOS update that corrects this issue. If a BIOS update is not available or is not convenient, then the alternative is to temporarily disable the Ultra ATA/66 (UDMA mode 4) or Ultra ATA/100 (UDMA mode 5) capability of your Quantum® or Maxtor hard drive until such time that a BIOS update is possible.

    Disabling either Ultra 66 or Ultra 100 on Quantum® drives can be accomplished by the use of a special utility available from Maxtor's Archived Utilities". You will need to locate and download the corresponding utility for your particular Quantum® Ultra 66 or Ultra 100 hard drive from this page.

    The files are listed on the software download page as "UltraDMA Change Utility". The same utility can also be used to restore the drive to its original factory Ultra ATA capability (66 or 100) at a later date if desired.

    Please review the UDMA 33 BIOS Update for disabling UDMA 66 or UDMA 100 on Maxtor drives.

    Disabling the UDMA option in the system's BIOS can be used as a temporary solution for systems that are running Windows 95/98 where the hard drive is being forced to run in MS-DOS compatibility mode.

    This should allow the hard drive to run in PIO mode-4 and operate in Windows 95/98 protected mode until either a BIOS update can be obtained, or Ultra-ATA/66 can be disabled on the hard drive.

    Affected chip sets include, but are not necessarily limited to, the following:
    · Intel Chipsets: 430TX, 440LX, 440BX
    · VIA Chipsets: 586A, 586B, 596, 686
    · SiS Chipsets: 5598, 5591, 5600, 530, 620
    · Ali Chipsets: 1543C, 1533A-J, 1543A1-F


    http://maxtor.custhelp.com/cgi-bin/m...nl_JnBfcGFnZT0
    Last edited by mrrobotto; 05-23-2003 at 09:19 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •